[pmwiki-users] A Farm, AuthUser, 2.2.0-beta63 and name/password not recognized

K.A.Bouton k.a.bouton at reading.ac.uk
Wed Nov 7 11:40:38 CST 2007

I have installed 2.2.0-beta63 and have a wiki farm, with SiteAdmin, And
TestFarm going just fine. Now I have tried to implement AuthUser.


1. In SiteAdmin/AuthUser I have


@admins: test


I have also set SiteAdmin/GroupAttributes?action=attr read/edit/attribute
all to @admins


2.in farmconfig.php I have near the top

$DefaultPasswords['admin'] = '@admins';

$DefaultPasswords['attr'] = '@admins';



3.In TestFarm/local/config.php I have near the top

$DefaultPasswords['read'] = array('@admins', 'id:test');





Now, when I try to read/edit any SiteAdmin files it gives me a login form
which works just fine - I can do all I want.


When I logout and goto TestFarm/Main/HomePage I am presented with a login
form - as expected. When I enter test and the password - a username which
just worked to get meinto theSiteAdmin files, I get redirected back to the
Form with Name/password not recognized.


I thought it might be the "login bug" I'd read about - so tried it via an
url?action=login - same problem.


How do I get it to work.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: /pipermail/pmwiki-users/attachments/20071107/eab31166/attachment.html 

More information about the pmwiki-users mailing list