[Pmwiki-users] Password problem

John Coxon john
Sun Dec 26 06:56:10 CST 2004

Maybe someone can shed some light on this little problem I'm having 
with passwords.

I've been running v2.0b10 as a wikifarm and just upgraded to v2.0b13 
with no change in this behavior.

In building my site I set passwords in the field local/config.php files:

$DefaultPasswords['admin'] = crypt('xxx');
$DefaultPasswords['edit'] = crypt('xxx');

I thought this was working as it should but now I'm not so sure :-) I 
now realize that sessions were never timing out. Once I started my 
browser and visited a page for an edit, after the initial password 
request I never got another password request on that page or anywhere 
else in the farm, even if I came back days later (assuming the browser 
was still running - or at least I think it was; maybe I'm just 
confusing the issue here)

Anyway, on to the problem of the day. Today I went to a page, made a 
large, time consuming edit - and lost it (grumble - growl). When I went 
to save it, I was asked for my password and since I had been editing 
for some time I thought maybe the session had expired. I entered the 
password and was looped back to the original unedited page.

I subsequently tried a test edit and preview instead of save. Same 
thing, a password request and a loop back to the original edit screen, 
no preview showing.

I then deleted the PHPSESSIONID cookie. Same symptoms. A new 
PHPSESSIONID cookie is getting set when the edit page is clicked.

I've been running Safari and tried FireFox - same symptoms which seems 
to rule out something on my Mac.

What could have changed overnight?


More information about the pmwiki-users mailing list